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Abstract

This short note introducesDesignLab which includes circuit simulation packagePSpice. This note is brief and a
detailed discussion can be found in various books on SPICE3[6] andPSpice [1, 5, 3].

1 Introduction

PSpice is a circuit simulation package. It is a commercial version of the legendary SPICE3 package (SIMULATION

PROGRAM WITH INTEGRATED CIRCUIT EMPHASIS) developed in the 70s. What normally goes by the namePSpice
is actually an integration of three packages. The first one isa Schematics capture program. This program enables the
user to graphically build circuits from a parts bin. The circuits developed usingSchematics are saved as.sch files. This
circuit information is then converted to a.cir (netlist) file which forms input to the packagePSpice. The netlist file.cir
is then processed byPSpice and the requested simulation is performed. The results of the simulation are output to a.out
file and a.dat file. FinallyProbe is used to plot the data from.dat file. MicroSim, the vendors and developers of these
packages, have named the suite of these packages asDesignLab.

To useDesignLab effectively, the user must first and foremost knowwhat they wantto do and then they must know how
to use theDesignLab to dowhat they wantto do. This document is an attempt to give a start in the use ofDesignLab.

1.1 Installation

To install the package is simple. Theftp distribution comes with a self-extracting and self-installing binary. The cd-rom
distribution has many more features in it; particularly thepdf format manuals. To install from it,dbl-clk onsetup.exe
and choose thePSpiceA D option. The programsSchematics, PSpice, andProbe are normally installed in the
DesginLab folder.

1.2 Suffixes

For a quick reference power-of-ten suffixes used byPSpice are given in Table 1.

SPICE3 Metric Prefix Value
F femto- 10−15

P pico- 10−12

N nano- 10−9

U micro- 10−6

M milli- 10−3

K kilo- 103

MEG mega- 106

G giga- 109

T tera- 1012

MIL milli-inch 25.4 × 10−6m

Table 1: SPICE3 Prefix Notation

SPICE3 suffixes are caseinsensitive; k andK mean the same. Also note thatF stands forfemto-and not Farads; a1F
capacitor to SPICE3 is 10−15 Farad capacitor. Also note that bothM andm meanmilli ; mega- isMEG or meg. Alphabets
other than the ones used as suffixes (Table 1) are ignored whenever they follow a number, also alphabets following a suffix
are ignored; e.g.,1mH is 10−3 Henry,1uF is 10−6 Farads, but10F for SPICE3 is10× 10−15 Farads, 1Ohm resistor is1Ω.

The normal sequence of programs to simulate a circuit is shown below. It is not necessary to useSchematics to create
the.cir file; the netlist file can be created just as easily using a texteditor.

Schematics → .sch
Schematics→ .cir

PSpice→ .dat
Probe→ Graphical Display

Schematics → .sch
Schematics→ .cir

PSpice→ .out
Text Editor→ Text Output
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2 Parts in Schematics

Schematics has almost all the parts that you are likely to use. To draw a schematic for analysis start theSchematics
program, open theParts Browser: Draw → Get New Part or CTRL-G. A dialog box as shown in Figure 1 will
appear. Click on any part name in the left hand side box and itspicture appears in the right hand side box and its description
appears in the box above it. If you can’t see the picture clickon Advanced>> and the picture should appear.

Figure 1: Parts Selection Dialog Box

You will see that the parts are listed in an alphanumeric order. To go to a particular part, click on the part list box and
type the first letter of the part name and the selection dialogwill take you to the first part in the list starting with that number
or alphabet. To learn how to locate the part you are looking for try Help in thePart Browser. A list of a few often
needed parts is given in Table 2.

Part Name Description Part Name Description
R Resistance C Capacitance
L Inductance K Mutual Coupling
VSRC Voltage Source (DC, AC, & Transient) ISRC Current Source (DC, AC, & Transient)
E Voltage-Controlled Voltage Source F Current-Controlled Current Source
G Voltage-Controlled Current Source H Current-Controlled Voltage Source
Dxxx Diode Qxxx Bipolar Transistor
S Voltage-Controlled Switch W Current-Controlled Switch
BUBBLE Node Label (dbl-clk to label) AGND or EGND Ground (node 0)

Table 2: Parts Table with Some Frequently Used Parts

Select the part you want and click onPlace. The part now attaches itself to the cursor; take the cursor to the schematic
sheet and click on it to place the part; click the right mouse button to release the part. In this way pick up all the parts. Once
the parts are picked they can be copied, cut, and pasted like in normal editors.Description Search box in Figure 1 is
very useful. Suppose you want to see all the parts with ‘voltage’ in their description; type ‘voltage’ in the box and search.
All the parts which match the description will appear. To getback to the master list of the parts, type ‘*’ in thePart Name
box.

2.1 Voltage & Current Source

ComponentsVSRC andISRC can be used for DC, AC, or transient analysis. For these two sources, three values can be
specified —DC, AC, and TRAN, whereDC value can be used for DC analysis,AC value can be used for AC analysis,
andTRAN can be eitherEXP, SFFM, SIN, PULSE, or PWL.

4



2.2 Controlled Sources

As an illustration two controlled-source circuits are presented. Figure 2 shows a circuit with voltage-controlled current
source. This circuit inSchematics is shown in Figure 3. The parts you need to pick are:VDC, IDC, BUBBLE, GND ANALOG ,
R, G. To connect them, getWire fromDraw → Wire or CTRL-W.

10V

1Ω

kVab

1Ω

1Ω 2A

a

+

b

-

Vab

Figure 2: Circuit with Voltage Controlled Current Source

To set value of resistors, current, and voltage source,dbl-clk on the value, a box will open up, fill the value you want
and close the box. To set the gain (sayk = 2) of the controlled source in Figure 3, select the sourceG and thenEdit →
Attributes or dbl-clk on the partG. A dialog box opens up; set the value ofGain = 2 andSave Attributes.
Note how bubbles are used to label the terminals. Two terminals are labelled ‘a’ and ‘b’ each. All the terminals with the
same label have the same potential. This means that in Figure3 both the terminals labelled ‘a’ have the same potential. This
feature keeps the schematic clean.
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Figure 3: A VCCS Circuit inSchematics

To analyse the circuit draw it as shown in Figure 3 and then setup the analysis. In this case it will be theBias Point
Detail: Analysis → Setup → click on the box next toBias Point Detail, OK, etc. Then run the simu-
lationAnalysis → Simulate orF11. If you have drawn the schematic correctly aPSpicewindow will appear on the
screen. Once the simulation is complete go toFile → Examine Output in PSpice or Analysis → Examine
Output Schematics and have a look at the analysis.

Figure 4 shows a circuit with current-controlled current source. This circuit inSchematics is shown in Figure 5. As
an exercise perform an analysis similar to the one above for the circuit Figure 5. What isVa?

Next we discuss four most important type of analyses. Each type of analysis is demonstrated using an example.

3 AC Sweep and Frequency Response

Figure 6 shows a simple RC circuit. HereV1 is a sinusoidal voltage1 × sin(2πft). We would like to know the relationship
between the input voltageV1 and the output voltage across the capacitorV2 as a function of the input sinusoidal voltage
frequency at steady-state.

5



10V

1Ω

kI

1Ω

1ΩRc

I

2A

a

+

b

-

Vab

Figure 4: Circuit with Current Controlled Current Source
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Figure 5: A CCCS Circuit inSchematics

3.1 Schematics

To draw the circuit shown in Figure 6 start theSchematics program from within theDesignLab program group. Once
the schematic window comes up go to theDraw menu and selectGet New Parts (short cutCTRL-G). The parts you
need to pick are:VAC , BUBBLE, GND ANALOG , R, C. Place the parts as you see in Figure 6 and then to connect them, get the
wire from theDraw menu (alsoCTRL-W). Connect the components. To label theBUBBLE dbl-clk on it and then type
the label you want that node to have. If you don’t labelBUBBLE theSchematics → netlist program will complain.
Labels can be any alphanumeric string. You will notice that the resistor and the capacitor don’t have the values you want for
them. To set the desired valuesdbl-clk on the ‘value’ of the part and then key in the desired value in the dialog box. You
will see that there is no place to set frequency of the AC voltage source V1; you can only set its magnitude. The reason being
that this source is used only forAC Sweep and the range of frequencies this source takes on have to be specified in analysis
setup step discussed in the next section.

To get the part with “V” inside a circle and an arrow connectedto node 2, go to theMarkers in the menu and choose
Mark Voltage/Level (CTRL-M) and place it appropriately. These markers do the job of voltmeters and ammeters.
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Figure 6: An RC circuit andAC sweep
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Once the simulation is complete you can change the position of the markers and the levels at the corresponding position will
be displayed in theProbe window. Now you can save the circuit.Remember that every schematic needs a ground with a
node label 0, without thisPSpice will complain of floating terminals and will not perform the simulation.

3.1.1 Analysis Setup

With the circuit captured using theSchematicswe now need to decide how to tellPSpice to get the frequency response.
PSpice can perform several types of analyses. By choosingAnalysis → Setup you are presented with the choices
shown in Figure 7. We need to decide which analysis will suit our needs.

Figure 7:Analysis Setup Menu

Before we do that let us have a quick look at the phasor analysis. From theory we know that the output voltage will
be of the same frequency as the input voltage frequency but ofdifferent magnitude and phase. In other words to know the
steady-state output voltage completely it’s sufficient to know its magnitude and phase shift. Phasor analysis is a simple way
to get this information. For the circuit in Figure 6, in the language of phasors (Let6 ~V1 = 0):

~V2 =

1

ωC1

R1 + 1

ωC1

~V1 =
~V1

1 + ωR1C1

In general the complex numberV2 will be a function ofω.

| ~V2| =
| ~V1|

√

(1 + (ωR1C1)2)
and 6 ~V2 = tan−1

(−ωR1C1

1

)

(1)

From equation (1) it can be seen that magnitude and phase of~V2 are dependent on the frequency. An evaluation of~V2 for vari-
ous frequencies is calledAC Sweep. On clicking theAC Sweep box of the menu in Figure 7, a box as in Figure 8 will open.
To setup our analysis here are the steps:Analysis → Setup → AC Sweep → (Decade; Pts/Decade: 20;
Start Freq: 1k; End Freq: 100k) -> OK etc.

Whenever we askPSpice to performAC analysis it sets all the DC sources and other time-varying sources to zero. It
considers only the sources for which an AC value has been specified and sweeps the frequency of all the AC sources together.

Having setup the analysis, to run the simulation:Analysis → Simulate (F11-key).

3.1.2 THE OUTPUT FILE

PSpice writes all its output in.out file. There is much important information there and you should have a look in it after
the simulation is complete. To open the.out file: in thePSpice windowFile → Examine Output or use an editor
to open it; it’s a text file. If there is an error in the netlist file or the simulation doesn’t complete the first place to look for the
exact description of errors is in the.out file.
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Figure 8:AC sweep Analysis Setup Menu

3.2 Probe

After PSpice successfully completes the simulation it should startProbe automatically. In case it doesn’t then start
Probe from the ‘program control window’ and then(File) → Open the corresponding.dat file. In Probe the fol-
lowing sequence of commands will generate the plot shown in Figure 9. From theProbe menu:
Trace → Delete All
Trace → Add → P() (right panel) → V(2) (left panel)
Plot → Add Plot
Trace → Add → M() (right panel) → V(2) (left panel)

1.0KHz 3.0KHz 10KHz 30KHz 100KHz

           Frequency
P(V(2))

0d

-40d

-80d

M(V(2))

1.0V

0.5V

0V
SEL>>

Figure 9: RC circuit andAC sweep output usingprobe

4 Transient Analysis

Transient analysis is performed to simulate the time response of circuits. A familiar example is when a square wave is applied
to a circuit with energy storage elements. In the following we will simulate the response of an RC circuit shown in Figure 10
due to a square wave.
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4.1 Schematics

+

-

V1
1k

R1

C1 1uF

0

2
1

VV

Figure 10: An RC circuit andTransient Analysis

Draw the schematic shown in Figure 10:
Draw → Get New Part → VPULSE
Select the voltage sourceV1 then eitherEdit → Attributes or dbl-clk and set the attribute values as follows:
DC=0; AC=0; V1=0; V2=5V; TD=0s; TR=1ns; TF=1ns; PW=5ms; PER=10ms
The pulse voltage waveform is shown in Figure 11. Drawing other components in the schematic Figure 10 is by now familiar
to you.

td tr

PW

tf

PERIOD

V1

V2

Figure 11: Pulse Voltage Source Specifications

4.2 Analysis Setup

Analysis → Setup → Disable all the previously selected analyses (except may beBias Point Detail). Then
setup theTransient analysis as follows:
Transient → (Print Step: 0.1ms; Final Time: 20ms) -> OK etc.

While performing the transient analysisPSpice sets all the AC voltage sources to zero. For a transient analysis there
must be at least one DC source or a time varying source. To set an initial voltage on a capacitordbl-clk on the capacitor
plates; a dialog box will open; change the value of theIC attribute to the value you want to set. Similarly theIC attribute of
an inductor can be set to any initial current.

Now start the simulation by either pressingF11-key orAnalysis → Simulate.

4.3 Probe

The plot in Figure 12 should now show in aProbe window once the simulation is complete. If it doesn’t show onits own
then:
Trace → Add → V(1) → OK → Trace → Add → V(2)
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0s 5ms 10ms 15ms 20ms

           Time
V(1) V(2)

6.0V

4.0V

2.0V

0V

Figure 12: RC circuit andTransient analysis output usingprobe

5 DC Sweep

To simulate a circuit for several values of DC voltage or current,DC sweep can be used.DC sweep is used in the following
example to trace the transfer characteristics of an inverting amplifier shown in Figure 13.

5.1 Schematics

Draw the schematic shown in Figure 13.
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Figure 13: Direct coupled amplifier andDC sweep

5.2 Analysis Setup

Setup theDC analysis as follows:
Analysis → Setup → DC Sweep → (Swept Var. Type: Voltage Source; Name: V1; Sweep Type: Linear;
Start Value: -1.5; End Value: 1.5; Increment: 0.1) -> OK etc.

5.3 Probe

In Probe the following sequence of commands will generate the plot you see in Figure 14. AfterPSpice successfully
completes the simulation it should startProbe automatically. In case it doesn’t, startProbe and(File) → Open the
corresponding.dat file. Then from theProbe menu:
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Trace → Delete All → OK → Trace → Add → V(2)

-1.5V -1.0V -0.5V 0V 0.5V 1.0V 1.5V

           V_V1
V(2)

20V

10V

0V

-10V

-20V

Figure 14: Direct coupled amplifier andDC sweep output usingprobe

6 PARAM Part – Parametric Analysis

At times it is desirable to simulate the circuit behaviour for changing component values.Parametric Analysis can
be used in conjunction withAC Sweep, DC Sweep, andTransient Analysis. To do so we must first declare it to
PSpice that a particular component’s value is to be varied during the analysis and then setup an appropriate analysis. This
is illustrated in the next example. In this example we want tofind the value of the resistorR2 for maximum power transfer
across it from the circuit.

6.1 Schematics

12

R1

+

-

20V

V2
+

-

2A

IDC

I1
5

R3

8R4 6R5

PARAMETERS:

10Rl

R2

{Rl}

0

Figure 15: Maximum Power TransferParametric analysis

Pick the parts from thePart Browser to set most of the circuit as you see in Figure 15. ThePARAMETERS: block
on the top is the partPARAM. Get this part and put it somewhere on the schematic. Nowdbl-clk on thevalueof the R2
resistor. This default value is normally 1k. In the dialog box type{Rl}. You can type any name there but it has to be within
curly braces. The curly braces tellSchematics that this is a parameter whose value will be set by thePARAMETERS:
block. Nowdbl-clk on thePARAMETERS: block and a dialog boxPM1 PARTNAME: PARAM opens up. In that box
set the value ofNAME1=Rl andVALUE1=10 (no curly braces aroundRl here). This value of ‘10’ is known as the nominal
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value. If any analysis is performed where theRl parameter is not varied then the nominal value is used for that analysis.
From thePM1 PARTNAME: PARAM dialog box it can be seen that we can declare upto three parametric parts using one
PARAM block.

6.2 Analysis Setup

Figure 16:Parametric Analysis Setup Menu

Analysis → Setup → DC Sweep → (Swept Var. Type: Global Parameter; Name: Rl; Sweep
Type: Linear; Start Value: 0.1; End Value: 50; Increment: 0.1) -> OK etc. as shown in
Figure 16.

6.3 Probe

In Probe the following sequence of commands will generate the plot you see in Figure 17. AfterPSpice successfully
completes the simulation it should startProbe automatically. In case it doesn’t startProbe and(File) → Open the
corresponding.dat file. Then from theProbe menu:
Trace → Delete All → OK → Trace → Add → I(R2)*I(R2)*Rl (in theTrace Expression box)
Tools → Cursor → Display
Tools → Cursor → Max

7 Probe

Probe is a plotting package which comes bundled withDesignLab. In aPSpice script (.cir file) you can either give
a command to save the entire simulation data or a few specifiedvoltages and currents. For example
.probe
will save the entire simulation data and
.probe v(2) v(5) I(R1)
will save the data for voltages at nodes 2 and 5 and the currentthrough resistor R1. If you are usingSchematics to build
the.cir file then it will automatically include statements to write the entire simulation data to a.dat file.
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B1:(15.800,6.3291)  B2:(100.000m,158.222m)  DIFF(B):(15.70...

0 10 20 30 40 50

           Rl
I(R2) * I(R2) * Rl

8.0

6.0

4.0

2.0

0

Figure 17: Maximum Power TransferParametric analysis output usingprobe

7.1 Trace → Add

Probe automatically plots the data on which you have either attached a voltage or a current marker in the schematic. Often
you would want to plot data and functions of data at other locations. Probe Trace → Add brings up the dialog box
shown in Figure 18. On the right panel it displays the functions available to the user. Let us assume that we have just
performed an AC sweep and now the data from that sweep has to beplotted. The currents and voltages at each node are
stored in separate arrays. In the language ofProbe, V(2) is an array of voltages at node 2 for different frequencies ofthe
AC sweep.clk onDB() in the right hand panel of Figure 18 andDB() appears in theTrace Expression dialog box
and the cursor is in between the round brackets. Now if youclk on V(2) theTrace Expression dialog box shows
DBV(V(2)). This means thatProbe will take each individual element ofV(2) take its20 log 10() and then plot it as a
function of frequency.

Here is a brief description of a few modifiers and the functions that you can use withProbe. To find out more
about the functions click on the Helpbox in the dialog box shown in Figure 18 thenDefining Analog Trace →
Expressions → functions.

Modifier Effect Example
M Magnitude (The default) VM(2) or M(V(2))— Magnitude of V(2)
P Phase VP(2) or P(V(2)) — Phase of V(2)
R Real Part VR(2) or R(V(2)) — Real part of V(2)
I Imaginary Part VI(2) or I(V(2))— Imaginary part of V(2)
DB 20 times log of value VDB(2) or DB(V(2))– 20log10(V (2))

Function Expression Comment
sgn(x) 1 for x > 0, -1 forx < 0, 0 ,x = 0
m(x) Magnitude ofx x may be comples
p(x) Phase ofx In degrees
r(x) Real part ofx
img(x) Imaginary part ofx
g(x) Group delay ofx
d(x) Derivative ofx With respect to X-axis
s(x) Integral ofx With respect to X-axis
avg(x) Running average ofx With respect to X-axis
avgx(x, d) Running average ofx from x− d to x Over range of X-axis
rms(x) Running RMS average ofx Over range of X-axis
db(x) Magnitude ofx in decibels
min(x) Minimum of real part ofx
max(x) Maximum of real part ofx
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Figure 18:Probe ‘Add Trace’ Dialog Box

7.2 Other Features

Many times it so happens that not all variables of interest can be plotted on the same plot. In that case you can request
Probe to open a new plot in the window. This is done byPlot → Add Plot. Clicking a plot window selects it and the
following Probe commands apply to that plot.

Probe has many more useful commands; you should explore theProbe menu to find out how to label axes, annotate
the graphs etc. You will often repeat the simulate→ plot cycle. To plot the same combination of variables you canlog the
Probe commands using theLog Commands menu item under theFile Menu and then replay them.

8 SPICE Model Parameters

The following description applies when creating netlist directly without usingSchematics. But it will also be a great help
when using thebreak parts to simulate semiconductor devices which don’t come withDesignLab.

8.1 The Model Statement

To include semiconductor devices inPSpice or SPICE3 we have to tell the simulator what are the characteristics of the
device. Different semiconductor devices have different properties unlike say a resistor. To specify a resistor all youhave
to do is to tell what’s its resistance and the job is done. SPICE3 has default values for all the semiconductor devices so if
you want to do some simple analysis you can tell the program that you are happy with the default values and in that case
your.model statement can be very simple. Here are a few sample pairs; thefirst statement gives the node connection of the
semiconductor device and the second is the.model statement.
D1 1 2 defd ; Diode (node sequence p-side n-side)
.model defd D ; default diode model
Q1 1 2 3 defq ; NPN transistor (node sequence C B E)
.model defq NPN ; default NPN model
Q2 1 2 3 defq2 ; PNP transistor (node sequence C B E)
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.model defq2 PNP ; default PNP model
J1 1 2 3 defj ; N-channel junction FET (node sequence D G S)
.model defj NJF ; default NJF model
J2 5 6 7 defjp ; P-channel junction FET (node sequence D G S)
.model defjp PJF ; default PJF model
M1 1 2 3 4 defm ; N-channel MOSFET (node sequence D G Source Substrate)
.model defm NMOS ; default NMOS model
M2 1 2 3 4 defmp ; P-channel MOSFET (node sequence D G Source Substrate)
.model defmp PMOS ; default PMOS model
Note that the in-line comments following ‘;’ are allowed only in PSpice.
There are a few important points to remember about the above statements.

• The first letter of every device should be exactly as given, e.g., when you want to include a BJT the first letter should
be Q, etc.

• The node sequence also is fixed. For example in the BJT declaration the first node after Qxxx has to be the collector,
then the base, and finally the emitter.

• defq in the declaration of Q1 above tells the program that the characteristics of the device connected here should be
looked up in the.model statement fordefq. There is no restriction on the name you choose for the model.

• The.model statement for a particular type of device should use only a particular word. For example, an NPN BJT has
to be declared by the letters NPN. The second word after.model above is the word reserved for that particular device.
Looking at the above statements you can get an idea of which word is used for which device. Many more devices than
shown above can be simulated withPSpice, for a complete list see [5] or browse through theSchematics parts
library.

• If you want to give the device values other than the default ones then you have to specify them following the reserved
word as done in the three scripts we presented before. To get an idea of what the default settings are look in the
.out file after performing a simulation. To find out which parameters mean what have a look in the text-book [2, pp
185-187].

8.2 Break Parts

Schematics makes provision for including parts which are not availablein its parts library. Parts whose parameters can
be changed are calledbreak parts. The difference between other parts and break parts isas follows. Other parts cannot be
saved in a different name and when you change their characteristics the record in the master file eval.lib gets changed. But
the break parts can be saved under a different name and so the change in device parameters is specific to the new part you
have created.

+

-
0.65V

V1

+

-

10V

VCC
MyBJT

Q1

0

Figure 19: BJT Characteristics

To createQ1 shown in Figure 19 chooseGet New Part (Ctrl-G) from theDrawmenu from within theSchematics,
then choose part ‘QbreakN’ and place it in the circuit. Now highlight the part ‘QbreakN’ and thenEdit → Model. Click
on Edit instance Model (Text)...’, a window appears with the contents shown in Table 3. You can edit the ‘.model’ command
so that it is something like you see in the script in Table 4. This process will save the model for you in a.lib file with the
same name as the name you give to the circuit. You can either directly change the model parameters by editing the.lib file
or repeat the process given above to change the model parameters.
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Remember that thePSpice has provided ‘break’ parts for you to copy and modify them to your requirements.
The first time theModel Editor window will come up you will see the following.

.model Qbreakn NPN

*$

Table 3: The Model Editor Dialog Box

You can changeQbreakn to sayMyBJT or any other name that takes your fancy. The values of the BJT parameters
shown in Table 6 can also be keyed in as shown below in Table 4. Note that a comma or a newline or a space can be used
to separate two values. After you edit the parameter values theModel Editor window might look something like seen in
Table 4.

.model MyBJT NPN
IS = 1e-15, BF=300
VAF=200 RB=0.01 RE=0.0001
TF=1n
CJE=1.2f
MJE=1.4

*$

Table 4: The Edited Model Editor Dialog Box

NestedDC Analysis is used to vary VCC and V1 in Figure 19 to get the transistor characteristics shown in Figure 20.
In Figure 20 collector current for changing VCC is plotted; V1 is held constant for each curve in the plot. As an exercise see
if you can setup the analysis and get a similar plot.

0V 0.5V 1.0V 1.5V 2.0V 2.5V 3.0V 3.5V

           V_VCC
Ic(Q1)

6.0mA

4.0mA

2.0mA

0A

Figure 20: BJT Characteristics output usingprobe

8.3 More SPICE3

As described above you can use break-parts to simulate circuits with parts not in theSchematics library. Alternatively
you can copy the models fromeval.lib which comes withPSpice; give models new names and change the model
parameters appropriately. If you are usingPSpice scripts you can create a library of your own. Let’s say you call it
mylib.lib then you can include the models in the library by using the following line:
.LIB "path\mylib.lib"
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You can also read in aPSpice script into the current script by including:
.INC "path\filename"
If you are usingSchematics then the library files etc. can be set from theAnalysis Menu. The .INC and .LIB
commands are not available in SPICE3.

Most of the manufacturers supply model files for the components they manufacture to make it easy for people using
SPICE3 to simulate circuits with their parts. You can search the net for manufacturer’s site and then download the models.
One good site to check out is the MicroSim site http://www.microsim.com.

9 Mathematical Models of Semiconductor Devices

This section gives a quick reference to the mathematical models of three often used devices. The correspondence between
the symbols used in text-books [2] and theSPICE3 symbols are given in the following Tables.

9.1 Semiconductor Diode

Iforward= ISe
Vj

NVT andIreverse= IBV e
−(Vj+BV )

VT

SPICE Text Description Units Defaults
Symbol Symbol
IS Is saturation current amp 10−16

N emission coefficient 1
BV reverse breakdown “knee” voltage amp ∞
IBV reverse breakdown “knee” current volt 10−10

RS parasitic resistance ohm 0
CJ0 Cj0 zero-biasp-ncapacitance farad 0
VJ φ0 p-npotential volt 1
EG EG bandgap voltage (barrier height) eV 1.11

Table 5: Semiconductor Diode Parameters

Zener diodes are included by setting the reverse breakdown voltageBV to the zener breakdown voltage value.

9.2 Bipolar Junction Transistor

gm =
IC

VT
; rπ =

βF

gm
; Cb = τF gm; ro =

VA

IC
; rµ = βF ro; Cje ≈ 2 Cje0;

Cπ = Cb + Cje; Cµ =
Cµ0

(

1 + VCB

ψ0c

)nc
; Ccs =

Ccs0
(

1 + VCS

ψ0s

)ns
;

IC = ISe
VBE
VT (1 + λVA) (2)

9.3 Junction Field Effect Transistor

ID = IDSS

(

1 − VGS

VP

)2

(1 + λVDS) (3)

ro =
1

λId
(4)

gm =
−2IDSS
VP

(

1 − VGS

VP

)

(5)

gm0 =
−2IDSS
VP

(6)
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SPICE Text Description Units Defaults
Symbol Symbol
IS Is Transport saturation current amp 10−16

BF βF Maximum forward current gain 100
BR βR Maximum reverse current gain 1
VAF VA Forward Early voltage volt ∞
RB rb Base Series resistance Ω 0
RE rex Emitter Series resistance Ω 0
RC rc Collector Series resistance Ω 0
TF τF Forward transit time sec 0
TR τR Reverse transit time sec 0
CJE Cje0 Zero-bias base-emitter depletion capacitance F 0
VJE ψ0e Base-emitter junction built-in potential volt 0.75
MJE ne Base-emitter junction-capacitance exponent 0.33
CJC Cµ0 Zero-bias base-collector depletion capacitance F 0
VJC ψ0c Base-collector junction built-in potential volt 0.75
MJC nc Base-collector junction-capacitance exponent 0.33
CJS Ccs0 Zero-bias collector-substrate depletion capacitanceF 0
VJS ψ0s Collector-substrate junction built-in potential volt 0.75
MJS ns Collector-substrate junction-capacitance exponent 0

Table 6: Bipolar Transistor Parameters

SPICE Text Description Units Defaults
Symbol Symbol
VTO VP Threshold voltage (pinch-off voltage) volt -2
LAMBDA λ Channel-length modulation parameter volt−1 0
BETA IDSS

V 2
P

Transconductance parameter amp/volt2 10−4

RD rd Series drain resistance Ω 0
CGS Cgs0 Zero-bias gate-source junction capacitance F 0
PB ψ0 Gate-channel junction built-in potential volt 1
CGD Cgd0 Zero-bias gate-drain junction capacitance F 0

Table 7: JFET Parameters

9.4 Metal Oxide Semiconductor Field Effect Transistor

ID =
k′

2

W

L
(VGS − Vt)

2
(1 + λVDS) (7)

ro =
1

λId
=
VA

ID
(8)

gm = k′
W

L
(VGS − Vt) (9)

k′ = µnCox = µn
ǫox

tox
(10)
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